False negatives

Feb 10, 2010 at 10:36 PM

On the whole, the addin is working as I would like - it does identify when I have forgotten an attachment.  This is something for which I am very, very, very grateful.  However, I am getting what I am calling false negatives - a message that an attachment is missing when none of the key words are present.  This only happens occaisonally.  I am also getting an exception message with some normal emails (no attachment, no key words) that has the following log entry

: C:\Users\lawrence.freedman\Documents\OARDiag0992.log
=========================
2/10/2010 8:43:58 AM
-------------------------
Source:
Message: Exception from HRESULT: 0x80040108
Stack:    at Microsoft.Office.Interop.Outlook._MailItem.get_ConversationIndex()
   at OutlookAttachmentReminder.OutlookAttachmentReminderAddin.Application_ItemSend(Object Item, Boolean& cancel)*************************
=========================

Hope this helps. 

Coordinator
Feb 11, 2010 at 2:38 AM

Thanks a lot for the notification. I think I have made code changes already to get rid of the exception messages. In my test machine I dont see it anymore. When the next version is released  (pretty soon) you should not see those exceptions. The code change is already reflected in the new Changesets of Code.

As far as the "False Negatives" are concerned, they sound interesting. I have never faced them myself, so I would need some more detail. When it happens next could you send a screenshot of the window of the mail and the OARDiag and OARWordlist file along with the words that matched?

Regards,
Das

Feb 11, 2010 at 12:56 PM

Das,

Did I mention I have been waiting for something like this since I started using email (and forgetting attachments)?  More thank yous.

I can send you screenshots when it happens.  I’m using the standard word list with no changes, but I’ll include the 2 files with the screenshot.

Larry

From: gouravdas [mailto:notifications@codeplex.com]
Sent: Wednesday, February 10, 2010 9:38 PM
To: Freedman, Larry
Subject: Re: False negatives [OAR:84003]

From: gouravdas

Thanks a lot for the notification. I think I have made code changes already to get rid of the exception messages. In my test machine I dont see it anymore. When the next version is released (pretty soon) you should not see those exceptions. The code change is already reflected in the new Changesets of Code.

As far as the "False Negatives" are concerned, they sound interesting. I have never faced them myself, so I would need some more detail. When it happens next could you send a screenshot of the window of the mail and the OARDiag and OARWordlist file along with the words that matched?

Regards,
Das

Read the full discussion online.

To add a post to this discussion, reply to this email (OAR@discussions.codeplex.com)

To start a new discussion for this project, email OAR@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
Feb 11, 2010 at 2:53 PM

Thanks a lot Larry. I am glad my effort is helping people in these small, but important issues.

I would wait for the files on next occurrence.

Jun 30, 2010 at 3:45 PM
For your additional information... I installed Attachment Reminder two days ago. It does show a message when any of the key words are in the message, but I also get an error message HRESULT: 0x80040108 when I select SEND on a message that does not have one of the keywords. I am running on Win 7, 64 bit laptop with Office 2007.
Jun 30, 2010 at 8:48 PM

I have removed OAR 0.9 and looked in sysWOW 64 for an item named OAR and there was none.  I then downloaded, and installed, the latest beta 1.0b and it shows as installed. Looking in sysWOW64 again there still is nothing named OAR. Is that normal?

I also was sending a message without any attachment and the same error message came up... HRESULT: 0x80040108.

AGAIN FYI: Win 7 64 bit with all updates and Office 2007. Let me know if you need any other information.

Coordinator
Jun 30, 2010 at 8:54 PM

Yes that is normal if you are not seeing any OAR related keys. But that error HRESULT: 0x80040108 is not normal. Could you send me the OARDiag log for 1.0 beta (assuming the same error occurred on 1.0 beta as well). You can mail it to das.vicky@gmail.com.

Does this happen all the time or intermittently? Does it happen on sending a new email or reply/forward? The diag might tell us in where we are throwing this error and then I can add instrumentation to figure out whats happenning.

Jun 30, 2010 at 10:10 PM

I have sent the log for 1.0b.

To confirm, it happened earlier when sending a new message but did NOT show in a reply message I sent, nor in another new message where I had three attachments.

Regards,
George

George Chenarides

(951) 515-5221 Cell

From: gouravdas [mailto:notifications@codeplex.com]
Sent: Wednesday, June 30, 2010 12:54 PM
To: cgeorge@lplocks.com
Subject: Re: False negatives [OAR:84003]

From: gouravdas

Yes that is normal if you are not seeing any OAR related keys. But that error HRESULT: 0x80040108 is not normal. Could you send me the OARDiag log for 1.0 beta (assuming the same error occurred on 1.0 beta as well). You can mail it to das.vicky@gmail.com.

Does this happen all the time or intermittently? Does it happen on sending a new email or reply/forward? The diag might tell us in where we are throwing this error and then I can add instrumentation to figure out whats happenning.

Read the full discussion online.

To add a post to this discussion, reply to this email (OAR@discussions.codeplex.com)

To start a new discussion for this project, email OAR@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 9.0.830 / Virus Database: 271.1.1/2973 - Release Date: 06/30/10 05:24:00

Jun 30, 2010 at 10:11 PM

When I selected SEND on this message the ERROR again showed up.

Regards,
George

George Chenarides

(951) 515-5221 Cell

From: George Chenarides [mailto:Cgeorge@LpLOCKS.com]
Sent: Wednesday, June 30, 2010 2:10 PM
To: 'OAR@discussions.codeplex.com'
Subject: RE: False negatives [OAR:84003]

I have sent the log for 1.0b.

To confirm, it happened earlier when sending a new message but did NOT show in a reply message I sent, nor in another new message where I had three attachments.

Regards,
George

George Chenarides

(951) 515-5221 Cell

From: gouravdas [mailto:notifications@codeplex.com]
Sent: Wednesday, June 30, 2010 12:54 PM
To: cgeorge@lplocks.com
Subject: Re: False negatives [OAR:84003]

From: gouravdas

Yes that is normal if you are not seeing any OAR related keys. But that error HRESULT: 0x80040108 is not normal. Could you send me the OARDiag log for 1.0 beta (assuming the same error occurred on 1.0 beta as well). You can mail it to das.vicky@gmail.com.

Does this happen all the time or intermittently? Does it happen on sending a new email or reply/forward? The diag might tell us in where we are throwing this error and then I can add instrumentation to figure out whats happenning.

Read the full discussion online.

To add a post to this discussion, reply to this email (OAR@discussions.codeplex.com)

To start a new discussion for this project, email OAR@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 9.0.830 / Virus Database: 271.1.1/2973 - Release Date: 06/30/10 05:24:00

Coordinator
Jun 30, 2010 at 10:13 PM

Thanks so much for notifying about this. I now know where this is coming from. I would need some time to track WHY that is happenning. Will release an updated version as soon as I figure that out. Till that point, you can continue using the current version without any harm.

Jun 30, 2010 at 10:16 PM

Glad it helped. Please let me know when the next fix is available.

Have a good day.

Regards,
George

George Chenarides

(951) 515-5221 Cell

From: gouravdas [mailto:notifications@codeplex.com]
Sent: Wednesday, June 30, 2010 2:14 PM
To: cgeorge@lplocks.com
Subject: Re: False negatives [OAR:84003]

From: gouravdas

Thanks so much for notifying about this. I now know where this is coming from. I would need some time to track WHY that is happenning. Will release an updated version as soon as I figure that out. Till that point, you can continue using the current version without any harm.

Read the full discussion online.

To add a post to this discussion, reply to this email (OAR@discussions.codeplex.com)

To start a new discussion for this project, email OAR@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 9.0.830 / Virus Database: 271.1.1/2973 - Release Date: 06/30/10 05:24:00

Coordinator
Jul 3, 2010 at 8:17 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.